OpenSSL“心脏出血”漏洞来袭,须尽快升级

标签:OpenSSL心脏出血漏洞

访客:17959  发表于:2014-05-08 16:35:00

OpenSSL:

    OpenSSL是一个强大的安全套接字层密码库,Apache使用它加密HTTPS,OpenSSH使用它加密SSH。OpenSSL为网络通信提供安全及数据完整性的一种安全协议,囊括了主要的密码算法、常用的密钥和证书封装管理功能以及SSL协议,并提供了丰富的应用程序供测试或其它目的使用。

    越来越多的网站使用加密代码来保护如用户名、密码和信用卡号等数据,这能够防止黑客通过网络盗取个人信息。

    这种加密协议被称为SSL(Secure Sockets Layer安全套接层)或TLS(Transport Layer Security Protocol安全传输层协议)。当一个网站使用这种安全协议,浏览器中的地址栏旁会出现挂锁图标。

    编写加密代码十分复杂,所以很多网站使用一种开源的免费安全协议,即OpenSSL。

    昨日,OpenSSL爆出其加密代码中一种名为Heartbleed的严重安全漏洞(CVE ID:CVE-2014-0160),黑客可以利用该漏洞从服务器内存中窃取64KB数据。据谷歌和网络安全公司Codenomicon的研究人员透露,该漏洞已经存在存在两年之久,三分之二的活跃网站均在使用这种存在缺陷的加密协议。

    该 Heartbleed bug 可以让互联网的任何人读取系统保护内存,这种妥协密钥用于识别服务提供者和加密流量,用户名和密码的和实际的内容。该漏洞允许攻击者窃听通讯,并通过模拟服务提供者和用户来直接从服务提供者盗取数据。

    目前仅OpenSSL的1.0.1及1.0.2-beta版本受到影响,包括:1.0.1f及1.0.2-beta1版本。

    由于“心脏出血”漏洞的广泛性和隐蔽性,未来几天可能还将会陆续有问题爆出。安恒信息建议广大互联网服务商尽快将OpenSSL升级至1.0。OpenSSL Project已经为此发布了一个安全公告(secadv_20140407)以及相应补丁:secadv_20140407:TLS heartbeat read overrun (CVE-2014-0160)。

评论(0)

您可以在评论框内@您的好友一起参与讨论!

<--script type="text/javascript">BAIDU_CLB_fillSlot("927898");